Nissan Juke : Juke Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello all,
I have a 13 Juke S and it seems to be having cold starting problem. I have suspicions that it might be the fuel pump relay. I have been looking around and cannot find anything about it. I know it has a fuel pump fuse based on the fuse diagrams but that is it. I have been looking at the relay box on the passenger side of the vehicle but I get conflicting information that those correspond to the horn relay or to the trailer hitch relay. I really would like to replace this before I take it to the dealership and can rule that out.
 

·
Administrator
Joined
·
12,143 Posts
Hello all,
I have a 13 Juke S and it seems to be having cold starting problem. I have suspicions that it might be the fuel pump relay. I have been looking around and cannot find anything about it. I know it has a fuel pump fuse based on the fuse diagrams but that is it. I have been looking at the relay box on the passenger side of the vehicle but I get conflicting information that those correspond to the horn relay or to the trailer hitch relay. I really would like to replace this before I take it to the dealership and can rule that out.
Cold start can be a lot more than just fuel. Why are you thinking its the relay and not the pump.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Cold start can be a lot more than just fuel. Why are you thinking its the relay and not the pump.
It happens intermittently, after a couple of tries, it starts right up. I imagine if the fuel pump were going when cranking the engine i would flood the cylinders. I am also asking this based on a post I saw from a couple years back:


I would like to replace that first before I make the dreadful trip to the dealership.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I'm only planning to replace that part (if it has one) , and if it does not fix the problem, I'll take it to the dealership.
 

·
Administrator
Joined
·
12,143 Posts
I never heard of Juke having a fuel pump relay going bad.

Bad plugs can cause a cold start issue. If you are having issues and do not know when your plugs were last replaced. Maybe start there.

There are two fuel pumps. Low pressure in the tank an high pressure on top of the engine.

Fuel pump and Injector relays are in a box to the left of the engine and next to the upper engine mount. Number 5 in the pic.

Schematic Font Engineering Parallel Rectangle
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Thank you for the information. I'll check the plugs and see what condition they are in. I'll probably end up taking it to the dealership.
 
1 - 7 of 7 Posts
Top