Nissan Juke : Juke Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2011 Nissan Juke, automatic CVT transmission.
I’ve noticed lately that when driving my traction control light will flash on for a brief moment and at the same time the car feels like it’s shifting gears, and then it’s fine.
If I shut the traction control off, it’s perfectly fine.
I just had new pads and rotors put on, but that didn’t change anything.
also if your using cruise control and this happens, the cruise control shuts off, just like if you had tapped the brakes.
Any ideas?
 

·
Administrator
Joined
·
11,701 Posts
I have a 2011 Nissan Juke, automatic CVT transmission.
I’ve noticed lately that when driving my traction control light will flash on for a brief moment and at the same time the car feels like it’s shifting gears, and then it’s fine.
If I shut the traction control off, it’s perfectly fine.
I just had new pads and rotors put on, but that didn’t change anything.
also if your using cruise control and this happens, the cruise control shuts off, just like if you had tapped the brakes.
Any ideas?
There are probably codes in the TCU. Take it someplace and have them look at it. Its most likely a simple fix but make sure your Brake fluid is topped off and your brake lights are working.
 

·
Super Moderator
Joined
·
4,342 Posts
I just reread your original post. You mentioned that you just had the brake pads replaced.

The recommended method to open the calipers is to bleed off the fluid and NOT push it back into the master cylinder. If done incorrectly, it screws up the ABS and probably affects the traction control system.
 
1 - 4 of 4 Posts
Top