Nissan Juke : Juke Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I tried to put led tail lights in my 2014 juke sv and now I dont have tail lights everything else works. Any help please
 

·
Super Moderator
Joined
·
1,495 Posts
Are they whole units with integrated bulbs and harness/housing or are they just replacement bulbs? Did you check polarity and install them the correct way? If they are bulbs, do they require load resistors wired in parallel? If you put regular bulbs back in and they work, then it's either the LEDs are bad, not the right kind for the Juke, or plug in incorrectly.

Welcome to the forums!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
They were single bulbs. I have taken them out and put regular bulbs in and still no tail lights
 

·
Super Moderator
Joined
·
9,515 Posts
You blew a fuse. Its in the BCM. The black box is next to the battery under the air intake pipe. I had it happen to mine. The fuses are on the cover. Its a pain but you can fix it.
 

·
Super Moderator
Joined
·
1,495 Posts
You blew a fuse. Its in the BCM. The black box is next to the battery under the air intake pipe. I had it happen to mine. The fuses are on the cover. Its a pain but you can fix it.
That's the IPDM in the engine bay next to the battery and intake. The IPDM handles more front of the car and engine related electrical. The BCM is under the steering wheel and behind the dashboard and controls more accessories and interior items. Access cover for the BCM is on the side of the dash when you open the driver door.

OP, like mentioned, you possibly blew a fuse in the BCM. check there and replace the fuse with a properly rated fuse.
 

·
Super Moderator
Joined
·
9,515 Posts
Whoops

If its not in the main fuse.

Its probably the IDPM. I had to replace that one like I said above.
 
1 - 7 of 7 Posts
Top