Nissan Juke : Juke Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So I have a 2013 nissan juke and I started it up this morning, no issues. I looked at the dash and noticed my battery and brake lights were both lit up. I hit the break to try and make sure it was completely in park ect.. when I pushed the break peddle down, the radio shut off and all of the electronic parts on my dash were gone, just black. I hit the push start button to turn it off and the engine just revved up instead of shutting off.. I ended up just holding the button down for about 5 seconds continuously and it turned off. Went to try and start it back up and now it's not coming back on. Has anyone experienced this before with all of these things happening at the same time? Everyone I've talked to has said they've never heard of the engine not turning off.. maybe even a few suggestions of what I could look at to start figuring out what's going on please? 😩
 

·
Super Moderator
Joined
·
2,276 Posts
welcome to the forums. I want to say I have seen at least one other post about a similar situation like this. Use the search function and see if you can find anything here.

Otherwise, you may have a few things going on. The brake and battery symbols illuminated means there is a potential problem with the alternator or charging circuit of the car, and possibly the battery/electrical system. Additionally, I know there were issues with the push to start button sticking, but I do not recall what model years were affected (may not have been the 2013 model year). Lastly, there could be an issue with the brake switches on the brake pedal. There are two of them. one or both of them may need cleaning, adjustment, or replacement.

I would get your Juke to a qualified mechanic or dealership to have them diagnose and troubleshoot further. What I have mentioned above are just starting points for troubleshooting.
 
1 - 2 of 2 Posts
Top