Nissan Juke : Juke Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
Just brought a low mileage juke 2011 recently,
but found out the aircon is working weird.
somehow the compressor is not engaged immediately but it takes sometimes to start working,
sometimes only a few minute but sometimes it takes upto half hour...
once the compressor kicked in, everything goes normal and the air is cold enough,
but today just facing the worst case, halfway driving the aircon compressor stopped and only get back to work likely about 20mins later.

anyone facing the same problem before? will it be compressor faulty?
 

Attachments

·
Registered
Joined
·
43 Posts
Discussion Starter · #3 ·
Sounds like you are low on Freon. Have someone put gauges on it and check. I think Autozone and Advance Auto do this work now
thanks, gonna have a look on this too,
anyway does juke have something like aircon relay? some told me this may trigger the symptom too,
but where's this thing? couldnt found in use manual....?
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #4 ·
flushed the system, refrigerant checked, compressor just changed by ex owner not long ago :(
but problem still occur....today just cut me off for 20mins on route
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #6 ·
Sounds like an a/c shop or dealer will be needed to debug your system. Sensors talk to the computer to control the system. They will be able to tell which one isn't communicating correctly.
too bad im here in malaysia, which juke isnt brought in officially by local nissan dealer.
gonna search for specialist soon:(
 

·
Super Moderator
Joined
·
11,602 Posts
It is most likely a sensor issue. There are some recent threads here in the forum that may help you.
 
  • Like
Reactions: souls

·
Registered
Joined
·
43 Posts
Discussion Starter · #8 ·
It is most likely a sensor issue. There are some recent threads here in the forum that may help you.
thanks, its been nearly 2 months
and here's little update bout my juke ac problem, hope it can help the next jukers with similar issue:

symptoms &sign:
  • compressor engaged slow, can be lag from 2-3mins until 20mins after engine running.
  • randomly cut off and randomly back to work, can be stop working for just awhile or even half hour.
  • blower works perfectly fine, but just blowing hot air.
  • works completely fine when compressor engaged and blowing freezy air.

what 've been done but not helping:
  • checked on refrigerant pressure, piping, compressor clutch, completely fine.
  • refrigerant flushed and refill. compressor oil too.

solution & result:
- put the car in d workshop running for test & diagnose, found out to be pressure switch sensor faulty. technician said its quite a rare case but everything back to normal after replaced.
 

·
Super Moderator
Joined
·
11,602 Posts
thanks, its been nearly 2 months
and here's little update bout my juke ac problem, hope it can help the next jukers with similar issue:

symptoms &sign:
  • compressor engaged slow, can be lag from 2-3mins until 20mins after engine running.
  • randomly cut off and randomly back to work, can be stop working for just awhile or even half hour.
  • blower works perfectly fine, but just blowing hot air.
  • works completely fine when compressor engaged and blowing freezy air.
what 've been done but not helping:
  • checked on refrigerant pressure, piping, compressor clutch, completely fine.
  • refrigerant flushed and refill. compressor oil too.
solution & result:
- put the car in d workshop running for test & diagnose, found out to be pressure switch sensor faulty. technician said its quite a rare case but everything back to normal after replaced.
Thank you so much for the reply back !!!!!!!
 

·
Registered
Joined
·
5 Posts
Just brought a low mileage juke 2011 recently,
but found out the aircon is working weird.
somehow the compressor is not engaged immediately but it takes sometimes to start working,
sometimes only a few minute but sometimes it takes upto half hour...
once the compressor kicked in, everything goes normal and the air is cold enough,
but today just facing the worst case, halfway driving the aircon compressor stopped and only get back to work likely about 20mins later.

anyone facing the same problem before? will it be compressor faulty?
I had the exact same problem and I see many more who are having the same. 3 new compressors later, I think it’s fixed.. An intelligent repair person isolated the problem rather quickly. Seems that the fan motor governs the AC functions and it seems that maybe ALL Jukes were made with faulty ones...Fan motor is now replaced and AC is working in all different scenarios!!! I’m almost am in disbelief, as even the Nissan dealership could not figure this out..I thought I was going to have to junk it, with just 60k miles on it..
Hope this helps..
 
1 - 10 of 10 Posts
Top