Nissan Juke : Juke Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
i got 2014 nissan juke 1.6 petrol,52k miles, it had accident passenger side wheel, suspension leg,wishbone, and passenger driveshaft replaced second hand parts. everytime when hit 20mph traction control comes up few times ,sometimes not coming up. Been to diagnostics mechanic, zero faults on reading, live data all wheels no faults. Potentialy could be mechanical fault rather than electric.... front brake pads a bit thin one side, could it be brakes, or wheel hub, or even abs sensor even there is no reading as i heard japanese cars do not give presice fault description unlike german cars. Any ideas please?
 

·
Administrator
Joined
·
12,032 Posts
Brake fluid level.

Bad speed sensor or ABS sensor.
 

·
Registered
2011, tekna, force red
Joined
·
35 Posts
i got 2014 nissan juke 1.6 petrol,52k miles, it had accident passenger side wheel, suspension leg,wishbone, and passenger driveshaft replaced second hand parts. everytime when hit 20mph traction control comes up few times ,sometimes not coming up. Been to diagnostics mechanic, zero faults on reading, live data all wheels no faults. Potentialy could be mechanical fault rather than electric.... front brake pads a bit thin one side, could it be brakes, or wheel hub, or even abs sensor even there is no reading as i heard japanese cars do not give presice fault description unlike german cars. Any ideas please?
I had a similar problem with mine some time back where traction control light was coming on around the same speed, turned out to be the steering angle sensor needed resetting after the lower arm was replaced
 
1 - 3 of 3 Posts
Top