Nissan Juke : Juke Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2012 nissan juke. My AC system does not cool the car if the car is on idle or if it is operating at lower speeds/lower RPM's. When the car speeds up to high city/highway speeds it kicks in and definitely works. At first i was told it could be the cooling fan control module or the fan shroud. I changed both and still the same issue. I checked the AC freon and its working perfectly. Any ideas or suggestions?
 

·
Premium Member
Joined
·
2,562 Posts
You need to have AC pressure gauges hooked up while engine is running to verify compressor is outputting correct pressures.

Also you need to verify proper radiator fan speed operation when engine is running. The Nissan Consult 3+ scan tool can operate the fan at all speeds to verify this.

Another thing that can affect AC performance is a restricted AC condensor, amount of refrigerant charge, and weak alternator output.


So unless you have all the tools to test all that you need to take it to an AC shop or Nissan Dealer.
 

·
Registered
Joined
·
3 Posts
I have a 2012 nissan juke. My AC system does not cool the car if the car is on idle or if it is operating at lower speeds/lower RPM's. When the car speeds up to high city/highway speeds it kicks in and definitely works. At first i was told it could be the cooling fan control module or the fan shroud. I changed both and still the same issue. I checked the AC freon and its working perfectly. Any ideas or suggestions?
Blower motor try that I had same probably last year 2019
 

·
Registered
Joined
·
196 Posts
I had the same issue, just bought a new blower motor and its blowimg cold air just like when I first bought it.
 

·
Registered
Joined
·
5 Posts
I have a 2012 nissan juke. My AC system does not cool the car if the car is on idle or if it is operating at lower speeds/lower RPM's. When the car speeds up to high city/highway speeds it kicks in and definitely works. At first i was told it could be the cooling fan control module or the fan shroud. I changed both and still the same issue. I checked the AC freon and its working perfectly. Any ideas or suggestions?
I had the exact same problem and I see many more who are having the same. 3 new compressors later, I think it’s fixed.. An intelligent repair person isolated the problem rather quickly. Seems that the fan motor governs the AC functions and it seems that maybe ALL Jukes were made with faulty ones...Fan motor is now replaced and AC is working in all different scenarios!!! I’m almost am in disbelief, as even the Nissan dealership could not figure this out..I thought I was going to have to junk it, with just 60k miles on it..
Hope this helps..
 
1 - 5 of 5 Posts
Top